Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 5 of 5
  1. #1
    Nev
    Nev is offline
    Veteran Enthusiast

    Join Date
    Feb 2006
    Posts
    8,835

    Microsoft.NET framework

    I don't quite get what this does, but I know it's necessary for a lot of programs..

    But, do I need to keep all the older versions too? I have 3.0, 1.1 and it's hotfix, and 2.0, totalling at about 175MB...

  2. #2
    Veteran Enthusiast BEER BEER STRONG's Avatar


    Join Date
    Jun 2005
    Location
    I am the liquor
    Posts
    5,853
    It's used for a few things. It's good because it supports multiple languages, but doesn't require multiple things to run them. (as in, you need Java to run Java applications, but .net supports quite a few different languages at once) From a programmers standpoint, it has a lot of useful libraries, making certain tasks a lot easier to code than from scratch

    It's needed for lots of programs because pretty much anything developed for windows, using a microsoft program after Visual Studio 6 relies on .net, because it's a totally different system of coding than the previous generation, meaning you need software to run it. I don't see why you should keep the old versions though, they don't serve much purpose....
    [center:16hbm10o]

    He lost all his friends
    He didn't need his friends
    He lived with his mother and repeated himself[/center:16hbm10o]

  3. #3
    Nev
    Nev is offline
    Veteran Enthusiast

    Join Date
    Feb 2006
    Posts
    8,835
    Okay Matt. I removed 3.0 anyways because I don't really want the program that needed it.

    And I removed 1.1 and it's hotfix since they're useless. Now, can I remove older versions of the MSXML parser?

    http://img213.imageshack.us/img213/8714/msxmldy1.png

  4. #4
    Veteran Enthusiast BEER BEER STRONG's Avatar


    Join Date
    Jun 2005
    Location
    I am the liquor
    Posts
    5,853
    Quote Originally Posted by Nev
    Okay Matt. I removed 3.0 anyways because I don't really want the program that needed it.

    And I removed 1.1 and it's hotfix since they're useless. Now, can I remove older versions of the MSXML parser?

    http://img213.imageshack.us/img213/8714/msxmldy1.png
    MSXML parser 4 is (according to some info I found) pretty outdated, and is on the fringe of becoming unsupported by microsoft. 5 and 6 are the two generally accepted ones (even though I have no idea what they do :P) so you might as well only keep 6.
    [center:16hbm10o]

    He lost all his friends
    He didn't need his friends
    He lived with his mother and repeated himself[/center:16hbm10o]

  5. #5
    Nev
    Nev is offline
    Veteran Enthusiast

    Join Date
    Feb 2006
    Posts
    8,835
    Okay. I removed the older versions and I'm fine, so I'll lock this up..


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •