Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 3 of 3
  1. #1
    Dedicated Member Swifty's Avatar
    Join Date
    Jun 2008
    Location
    Sin City
    Posts
    850

    Windows 7 no "network adapters" tab in device manager

    I'm accesing the web with my iTouch but I bought windows 7 yesterday and I can't connect to the Internet the "local area connection" option won't show up either and I don't have the driver for my netgear router I need help my router is the WGR614v9. Thanks
    [center:15kh9l7l]
    Got Swift??[/center:15kh9l7l]

  2. #2
    Fanatic Enthusiast Niall's Avatar

    Join Date
    Aug 2007
    Posts
    3,298

    Re: Windows 7 no "network adapters" tab in device manager

    Seems like you can get the necessary drivers here - http://www.filecluster.com/Drivers/Netw ... mware.html

    I don't really know much about internet connection stuff but if that doesn't work there's a thread here where someone seems to have a similar problem - http://forum1.netgear.com/showthread.php?t=44672


    Dunno if that helps, just thought I'd briefly look.

  3. #3
    Dedicated Member Swifty's Avatar
    Join Date
    Jun 2008
    Location
    Sin City
    Posts
    850

    Re: Windows 7 no "network adapters" tab in device manager

    The guys at Microsoft said that my XPs drivers were too outdated any body have any links to Windows 7 HP drivers, like I said I'm using an itouch
    [center:15kh9l7l]
    Got Swift??[/center:15kh9l7l]


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •