Hello and welcome to our community! Is this your first visit?
Register
Results 1 to 6 of 6
  1. #1
    Fanatic Enthusiast Niall's Avatar

    Join Date
    Aug 2007
    Posts
    3,298

    Localhost blank page

    I had XAMPP installed aaages back for some web stuff, I uninstalled it a few months ago though. Ever since then when I tried to access localhost or 127.0.0.1 it'd immediately go to a blank page, with the url as a title (not too strange, I'd expect it to come up with some sort of connection / 404 error though).

    For the past couple of days I've been trying out different things like WAMP, XAMPP again and Z:WAMP. Between each program I'd installed and uninstalled them correctly, but no matter what, when I tried to access localhost, it was that same blank page. Like something was blocking it.
    Using Windows 7 & Firefox.

    Any help?

  2. #2
    Pen
    Pen is offline
    Enthusiast

    Join Date
    Mar 2009
    Posts
    1,282

    Re: Localhost blank page

    make sure your mysql, and apache ports are open. And make sure to start up Xampp, I some times forget to when I need to use it. Also, I believe there is a install file that you need to do first, though I could be wrong, its been a year since I've installed XAMPP on any computer.

  3. #3
    Fanatic Enthusiast Niall's Avatar

    Join Date
    Aug 2007
    Posts
    3,298

    Re: Localhost blank page

    XAMPP was running, Apache & MySQL services were started too. What do you mean "make sure your mysql and apache ports are open"? Also keep in mind this isn't just an issue with XAMPP - I like the look of Z:WAMP and might switch to that.

    Oh, important piece of info I forgot - the specific error on all 3 was something along the lines of "Apache web server is down". MySQL didn't seem to have any issues.

    e: actually, I remember XAMPP displaying that Apache was running, but the text logs beneath the toggles had an error relating to apache too.

  4. #4
    Insanity Skype's Avatar



    Join Date
    Apr 2007
    Location
    England
    Posts
    27,397

    Re: Localhost blank page

    Reinstall somewhere else and make sure your hosts file isn't making 127.0.0.1 point somewhere else.

  5. #5
    Pen
    Pen is offline
    Enthusiast

    Join Date
    Mar 2009
    Posts
    1,282

    Re: Localhost blank page

    Oh, I just thought about this as well. If your running Skype, Apache and skype have the same ports, these could be your error. Sorry, I'm not exactly sure, I've never had that error before.

  6. #6
    Fanatic Enthusiast Niall's Avatar

    Join Date
    Aug 2007
    Posts
    3,298

    Re: Localhost blank page

    Quote Originally Posted by Mr. Farley
    Oh, I just thought about this as well. If your running Skype, Apache and skype have the same ports, these could be your error. Sorry, I'm not exactly sure, I've never had that error before.
    That was it, thanks.


 

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •